Lietotāja rīki

Vietnes rīki


linux:mikrotik:torrentu-blokesana

Torrentu bloķēšana Mikrotik

Iespējams, ka pats vienkāršākais, bet efektīvs torrentu bloķēšanas paņēmiens Mikrotik rūteros.

/ip firewall filter
add ac=drop ch=forward p2p=a
add ac=drop ch=forward in-int=ether2 pr=udp cont=«d1:ad2:id20:» dst-port=1025-65535 packet-s=95-190
add ac=drop ch=forward in-int=ether2 pr=tcp cont=«info_hash=» dst-port=2710,80 

Opcionāli:

- aizliedzam .torrent failu lejupielādi

add ac=drop ch=forward cont="\r\nContent-Type: application/x-bittorrent" out-in=ether2 pr=tcp src-p=80

- Bloķējam lokālos torrentus

add ac=drop ch=forward cont="\r\nInfohash: " in-in=ether2 pr=udp dst-port=6771

Pēc idejas - noteikumiem ir jāstrādā jebkurā normālā rūterī, kas māk analizēt trafiku.

Citas torrentu bloķēšanas metodes

  1. Aizliegt visu. Atļaut darbu tikai vajadzīgiem portiem. :!: Ir jātur ciet porti virs 1024, kā arī tiek aizvērts arī citas noderīgas lietas.
  2. Liegt piekļuvi visiem torrent saitiem. :D Neviens neaizliedz magnet saiti iegūt savādākā veidā, kā arī visus saitus neaizvērsi.
  3. Ļaut iziet tikai izmanojot proxy. Ne visa programmatūra prot darboties caur proxy.

Avots: How to Block torrent 100%? Only 2 lines. It is solved

linux/mikrotik/torrentu-blokesana.txt · Labota: 04.06.2014 09:16 , labojis Imants